[XProtect]標準アップデート macOS15用更新 修正
2箇所にわかれているXProtect.bundleとXProtect.appのバージョンを引くようにした
サンプルコード
行番号 | ソース |
---|---|
001 | #!/bin/bash |
002 | #com.cocolog-nifty.quicktimer.icefloe |
003 | #修正 XProtect update をsoftwareupdateの後にした |
004 | #参考 |
005 | # https://eclecticlight.co/ |
006 | ################################################# |
007 | ###管理者インストールしているか?チェック |
008 | USER_WHOAMI=$(/usr/bin/whoami) |
009 | /bin/echo "ExecPriv(whoami): $USER_WHOAMI" |
010 | ###実行しているユーザー名 |
011 | CONSOLE_USER=$(/bin/echo "show State:/Users/ConsoleUser" | /usr/sbin/scutil | /usr/bin/awk '/Name :/ { print $3 }') |
012 | /bin/echo "ConsoleUser(scutil): $CONSOLE_USER" |
013 | ###STAT |
014 | STAT_USR=$(/usr/bin/stat -f%Su /dev/console) |
015 | /bin/echo "STAT_USR(console): $STAT_USR" |
016 | #OS |
017 | STR_PLIST_FILEPATH="/System/Library/CoreServices/.SystemVersionPlatform.plist" |
018 | STR_OSVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" ProductUserVisibleVersion) |
019 | /bin/echo "OSver: ${STR_OSVER}" |
020 | #バージョン |
021 | STR_PLIST_FILEPATH="/private/var/db/SystemPolicyConfiguration/XProtect.bundle/Contents/Info.plist" |
022 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
023 | /bin/echo "SystemPolicy bundle: $STR_XVER" |
024 | #バージョン |
025 | STR_PLIST_FILEPATH="/private/var/db/SystemPolicyConfiguration/XProtect.app/Contents/Info.plist" |
026 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
027 | /bin/echo "SystemPolicy Xprotext: $STR_XVER" |
028 | #バージョン |
029 | STR_PLIST_FILEPATH="/private/var/db/SystemPolicyConfiguration/XProtect.app/Contents/XPCServices/XProtectPluginService.xpc/Contents/Info.plist" |
030 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
031 | /bin/echo "SystemPolicy XPC: $STR_XVER" |
032 | #バージョン |
033 | STR_PLIST_FILEPATH="/Library/Apple/System/Library/CoreServices/XProtect.app/Contents/Info.plist" |
034 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
035 | /bin/echo "Library Xprotex: $STR_XVER" |
036 | #バージョン |
037 | STR_PLIST_FILEPATH="/Library/Apple/System/Library/CoreServices/XProtect.app/Contents/XPCServices/XProtectPluginService.xpc/Contents/Info.plist" |
038 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
039 | /bin/echo "Library XPC: $STR_XVER" |
040 | #バージョン |
041 | STR_PLIST_FILEPATH="/Library/Apple/System/Library/CoreServices/MRT.app/Contents/Info.plist" |
042 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
043 | /bin/echo "Library MRT: $STR_XVER" |
044 | |
045 | #チェック |
046 | /usr/bin/sudo XProtect check |
047 | #バージョン |
048 | XProtect version |
049 | #ソフトウェアアップデート |
050 | /usr/sbin/softwareupdate --list --include-config-data |
051 | /usr/sbin/softwareupdate --install --recommended --include-config-data |
052 | #アップデート |
053 | /usr/bin/sudo XProtect update |
054 | #バージョン |
055 | XProtect version |
056 | #ステータス |
057 | XProtect status |
058 | #スキャン |
059 | /Library/Apple/System/Library/CoreServices/XProtect.app/Contents/MacOS/XProtect |
060 | |
061 | |
062 | #バージョン |
063 | STR_PLIST_FILEPATH="/private/var/db/SystemPolicyConfiguration/XProtect.bundle/Contents/Info.plist" |
064 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
065 | /bin/echo "SystemPolicy bundle: $STR_XVER" |
066 | #バージョン |
067 | STR_PLIST_FILEPATH="/private/var/db/SystemPolicyConfiguration/XProtect.app/Contents/Info.plist" |
068 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
069 | /bin/echo "SystemPolicy Xprotext: $STR_XVER" |
070 | #バージョン |
071 | STR_PLIST_FILEPATH="/private/var/db/SystemPolicyConfiguration/XProtect.app/Contents/XPCServices/XProtectPluginService.xpc/Contents/Info.plist" |
072 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
073 | /bin/echo "SystemPolicy XPC: $STR_XVER" |
074 | #バージョン |
075 | STR_PLIST_FILEPATH="/Library/Apple/System/Library/CoreServices/XProtect.app/Contents/Info.plist" |
076 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
077 | /bin/echo "Library Xprotex: $STR_XVER" |
078 | #バージョン |
079 | STR_PLIST_FILEPATH="/Library/Apple/System/Library/CoreServices/XProtect.app/Contents/XPCServices/XProtectPluginService.xpc/Contents/Info.plist" |
080 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
081 | /bin/echo "Library XPC: $STR_XVER" |
082 | #バージョン |
083 | STR_PLIST_FILEPATH="/Library/Apple/System/Library/CoreServices/MRT.app/Contents/Info.plist" |
084 | STR_XVER=$(/usr/bin/defaults read "$STR_PLIST_FILEPATH" CFBundleShortVersionString) |
085 | /bin/echo "Library MRT: $STR_XVER" |
086 | |
087 | exit 0 |
AppleScriptで生成しました |
| 固定リンク
「Admin Maintenance」カテゴリの記事
- [メンテナンス]ユーザーログファイルをゴミ箱に入れる(2024.11.30)
- [XProtect]アップデート macOS15.1.1(2024.11.20)
- [メンテナンス] Containers以下サンドボックスアプリのキャッシュを全部ゴミ箱に入れる(2024.11.09)
- [メンテナンス]Thumbs.dbやDS_Store等をゴミ箱に移動させる(2024.11.09)